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OnSSET/Global 
Electrification Platform 
Hands-on 6: How to run an electrification analysis using 

GEP Scenario Generator1 

Installation: 

1. First, go here and click Clone or download > Download zip to download the 

GEP scenario generator. 

2. This exercise has a prerequisite that you have Jupyter Notebook 

https://jupyter.org/install.html and Python (you can use Anaconda to download 

all needed Python packages 

https://docs.anaconda.com/anaconda/install/installed) on your computer. 

Learning outcomes 
By the end of this exercise, you will be able to:  

1) Run a scenario for Benin in the GEP scenario generator 

2) Perform different key processes in the GEP scenario generator 

3) Create maps in QGIS to visualize the results. 

 

1 This exercise is an exercise developed by Korkovelos, A., Sahlberg, A., Khavari, B., 2019. 

Exercise 6: How to run an electrification analysis using GEP scenario generator [WWW 

Document]. OnSSET Teaching Kit. URL 

https://onsset.github.io//teaching_kit/courses/module_2/Excercise%206/ (accessed 2.18.21). 

All images are screenshots from gep-onsset in Jupyter notebook unless stated otherwise, 

which is licensed under MIT license. 

 

https://github.com/global-electrification-platform/gep-onsset
https://jupyter.org/install.html
https://docs.anaconda.com/anaconda/install/installed
https://onsset.github.io/teaching_kit/courses/module_2/Excercise%206/
https://github.com/global-electrification-platform/gep-onsset/blob/master/LICENSE
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GEP Scenario Generator (OnSSET) 

The objective of this session is to learn how to use the GEP Scenario 

Generator (OnSSET) tool to run an electrification scenario. This covers the 

basic operations of the Jupyter Notebook, how to enter input data, and 

where to find them. 

 

  
Figure 1 

(Picture source: gep-onsset GitHub page https://github.com/global-electrification-platform/gep-onsset license under MIT) 

Save and un-zip the folder, which will be named gep-onsset-master. This contains all 

of the code required to run the electrification analysis. Also, create a folder named 

Results where you want to save the results of your analysis. Apart from this, you will 

need the csv-file containing the extracted GIS data from last week’s exercise. Go to the 

gep-onsset-folder and open Jupyter Notebook. 

Exercise 1: Data acquisition and 
insertion to the electrification model  
Click on the GEP_generator.ipynb file, which is the interface for running the electrification tool. 

 

 

https://github.com/global-electrification-platform/gep-onsset
https://github.com/global-electrification-platform/gep-onsset/blob/master/LICENSE
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Figure 2 

Next, select the first cell with the Welcome to the GEP Generator header. When 

selected, the cell should be surrounded by a border with a blue line to the left.  

 
Figure 3 

 

Click the run button to run the cell. While running a code cell, the mode circle in the 

upper right corner is full while the process is running, and empty again once the 

process is finished. Note that this may go very quickly for some cells, while others take 

longer time.  

Once a process is finished, the selection automatically moves on to the next cell. 

 
Figure 4 

 



 
 

CCG 2021                                                                                                                                               Page | 4  

Run the first cell to load the code.  

 
Figure 5 

 

Step 1. GIS data selection.  

Run the next cell. This opens up the window below, click OK to open the browser. 

Browse to where the input file with all the extracted GIS data is located and select it.   

 

 
Figure 6 
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Step 2. Modelling period and target electrification rate. 

First, enter the start year and end year as well as the target electrification rate by the 

end year. Then run the cell. For the intermediate year of 2025 leave the default values 

as they are. 

 

 
Figure 7 

Step 3. Levers 

Move on to the lever section. In each of the cells, follow the description of the lever and 

enter the value of your choice. Remember to run each cell before moving on to the next 

one. 

For Prioritization choose 5 for Nationwide least-cost approach. 

Step 4. Enter country specific data 

In addition to the levers above, the user can customize a large number of variables 

describing the social, economic, and technological environment in the selected country. 

In total ~100 variables can be adjusted in this section.  

For Benin you should collect the data from different sources. These can be, but not 

limited to, data.worldbank.org, dataportal.opendataforafrica.org, esa.un.org/unpd/wup, 

UN Household Size and Composition Around the World 2017 etc., and national 

statistical offices. If you cannot find all of the input data, then keep the default value. 

NOTE that you need to at least collect the population (start and end year), 

urbanization rate (use the same at end year as 2018 if you do not find any other 

data), national electrification rate, and household size for this exercise. 

For the social input parameters, under a. Demographics and Social components enter: 

• the population in 2018 (e.g. 10870000”) 

• the projected population by 2030 (e.g., “15507000”) 

• the urban population share in 2018 (e.g., “0.44” for 44%) 

• the projected urban population share in 2030 (e.g., “0.51”) 

https://data.worldbank.org/
http://dataportal.opendataforafrica.org/
https://esa.un.org/unpd/wup/
http://www.un.org/en/development/desa/population/publications/pdf/ageing/household_size_and_composition_around_the_world_2017_data_booklet.pdf
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• the number of people per household in urban areas by 2030 (e.g., “3.1”) 

• the number of people per household in rural areas by 2030 (e.g., “3.6”) 

• the national electrification rate in 2018 (e.g., “0.41” for 41%) 

• the national urban electrification rate in 2018 (e.g., “0.41” for 41%) 

• the national rural electrification rate in 2018 (e.g., “0.41” for 41%) 

In case no other values have been collected then the default values can be used. 

Continue with Step 4 and run all the cells there. 

Step 5. GIS data import and processing 

Run the first cell in Step 5. This calibrates the population and provides some additional 

basic information based on the GIS data. If successfully run, a preview should appear 

with a preview of the GIS input data. If this table does not appear, or does not appear 

correctly, this may be caused either by an error in the csv-file or the code.  

 
Figure 8 

Based on the input data in the previous steps, in the next cell the code now creates 

some additional layers that are useful for the electrification analysis. This can be an 

iterative process which requires calibration from the user. One of the most important 

steps in the electrification analysis is the identification of the currently electrified 

settlements. Based on their location, the model then decides how easy it is to extend 

the grid to neighbouring cells, or rather choose an off-grid technology. 

The model calibrates which settlements are likely to be electrified in the start year, to 

match the national statistical values defined above. A settlement is considered to be 

electrified if it meets all of the following conditions: 

- Has more night-time lights than the defined threshold (this is set to 0 by 

default). 

- Is closer to the existing grid network than the distance limit. 

- Has more population than the threshold. 
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First, define the threshold limits. Then run the calibration and read the message on the 

bottom to check if the results seem okay. Else, redefine these thresholds and run again.  

 

 
Figure 9 

Run the next cell to plot the settlements that are calibrated as electrified (blue) and 

unelectrified (yellow) in the previous step. 
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'

 
Figure 10 

 

Step 6. Define the demand 

Here you can adjust the demand in the scenario further. You may change the number 
of kWh/household/year a Tier represents or add demand for productive uses of 
electricity. Note that there is no pre-defined method of estimating the demand for 
productive uses in the model. Run both cells and move on to the next step. 
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Step 7. Start a scenario run 

This step runs the algorithm to calculate the least-cost electrification technology in 
every settlement of the country. Note that this will take some time (from minutes to a 
couple of hours depending on your country).  

Step 8. Results, Summaries and Visualization 

After completing steps 1–7 the analysis is completed. Run all the cells in Step 7 to 
retrieve the results. These are presented as summary tables and a simple map.  

 
Figure 11 

(Picture source: OnSSET teaching material: https://doi.org/10.5281/zenodo.457403 licensed under CC-BY 4.0) 

Step 9. Exporting results 

In the first cell, name your scenario. In the next cell, run it and click OK in the box that 
appears, and browse to the folder where you want to save your results. Run the final 
cell to save two csv-files with information for each settlement and summaries for the 
whole country. The csv-file named “Results” can be used to generate maps in QGIS. 

 

https://doi.org/10.5281/zenodo.457403
https://creativecommons.org/licenses/by/4.0/legalcode
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Visualization of electrification results in 
GIS  

All images in this section are screenshots from QGIS 3.10, which is licensed under Attribution-

ShareAlike 3.0 Unported (CC BY-SA 3.0) unless stated otherwise.  

 

The following section provides a guide to the basic steps one must take in order to 

visualize the results of the electrification in a QGIS environment. Please follow the step-

by-step process and in case you have further questions you can use the OnSSET forum. 

Step 1. Importing the .csv file with the results 
After running your OnSSET analysis you will have a csv-file with the results. If you 
simply import this csv-file into any GIS software you will get a point layer. When 
visualizing your results, we would, however, like to visualize the clusters that you have 
used for the population layer. The instructions below will explain how to visualize your 
csv-file with your population clusters.  

1. Start with importing your csv by going to Layer → Add Layer → Add 
Delimited Text Layer. 

 

Figure 12 

 

2. The following window will open up: 

https://qgis.org/downloads/
https://creativecommons.org/licenses/by-sa/3.0/
https://groups.google.com/g/onsset
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Figure 13 

 

3. Under File format make sure that CSV (Comma separated values) is checked. A 

preview of the file is seen in the bottom of the window. Click Ok. Next, the 

coordinate system of the layer must be defined. In the Geometry CRS box, select 

WGS84. Also, in the X field and Y field select X_Deg and Y_Deg. Finally, 

click Add to load the layer. When the file is loaded (which might take some time) 

you should be able to see the file in the Layers Panel at the bottom left of your 

screen. 
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Figure 14 

 

4. After clicking on Add you will see that you have added a point layer to your map 
canvas.  
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Figure 15 

 

5. Now add the clusters that you used as your population layer during the 
extraction process by going to Layer → Add Layer → Add Vector Layer or 

simply drag it onto your map canvas.  

6. Now we will merge the layers. Open the toolbox and search for “Join attributes 
by field value”. 
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Figure 16 

 

7. The following window opens up: 

 

 
Figure 17 
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The idea behind this tool is to take the attribute table of one layer and add it to 
the attribute table of another layer using a field in each layer as identifier.  

The field Input layer defines the layer that you will see. Since we want to see 
clusters and not points, we will choose the population clusters in this field. 

Table field is the name of the field in the attribute table that will be used as 
identifier during the merge. Choose the file named ID. 

The field Input layer 2 defines the second layer. Select the point layer defined 
by your .csv file.  

The field named Table field 2 is the name of the field in the attribute table of 
the second layer that will be used as the identifier during the merge. Choose the 
field named ID. This means that all the rows with the same ID in your population 
clusters and your input file will be matched to one another. 

Do not change any of the other options. 

When finished click on Run in Background. 

Step 2. Displaying useful information in QGIS  

The map of the imported csv-file does not convey much information at first. Change 

this by right-clicking on the joined layer in the Layer Panel and choose Properties. 

Select the Style tab and at the top change from Single symbol to Categorized. 

Next, choose the Column option, and from the drop-down list scroll down and choose 

MinimumOverall2030 to display the technology option that can provide electricity at 

the lowest LCOE in each cell in 2030. Next, click on Classify to show all technology 

options that are utilized in the results. 

After choosing what to display, one must also make sure that the information can be 

understood clearly. The first step is to change the appearance of the symbols. Click on 

Change… in the Symbol box and then on Simple marker (Fig. 10); then on Outline 

select Transparent boundary and press Ok. You may change the colour of the symbols 

by double-clicking on them and modifying their appearance. Finally click Apply and then 

Ok to display the map. It will take some time for the map to draw in QGIS. 
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Figure 18 

 
Figure 19 
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The next step is to add some informative text and figures to the map. In QGIS this can 

be done in the Print Composer view. Open it by selecting Project > New Print 

Composer (Fig. 11). 

 

Figure 20 

This will prompt you to choose a name for your map. Choose a name and click OK or 

leave it blank to use a random name (Fig 21).  

 

Figure 21 

At this stage the map canvas opens (Fig. 22). 
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1. First set the properties of your map on the right-hand side of the image above in 

the Composition tab. Set Presets to A4 and choose Orientation as Portrait. Leave 

the rest as it is.  

2. Next, under Export settings (still on the right-hand side of the image above) you 

can set the resolution. For the purpose of these exercises 300 dpi is sufficient. This 

option is also set in the menu for composition.   

3. On your left-hand side you have a number of different tools that you can use for 

opening maps and preparing your map.  

 

Figure 21 

 

4. Click on Add new map on the left-hand side of the window (Fig. 23) to 

start creating a map. 
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Figure 23 

 

5. Next, put the cursor in one corner of the paper and click and drag to define the 

area the map should extend to (Fig. 24). The display of the normal QGIS window 

will appear in this area. 

 

Figure 24 

6. In the QGIS map composer every item (e.g., Legend, Title, Scale bar) may be 

edited by clicking on the item and then choosing the Item Properties tab on the 

right. This includes the size, scale, position, extent, and other attributes.  
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7. Add Title, Legend, and Scale bar from the menu to the left. Adjust their position 

and style to create an informative map. 

8. After finalizing the content of the map, check the boxes Lock layers and Lock 

styles for layers (Fig. 25). This ensures that if you turn off some layers or change 

their styles in the original window, the view will not change in the composer 

window.  

 

Figure 25 

9. Finally, export the map as a picture by clicking the  icon, and save it in the 

Results folder. 

Once the map of technology split is satisfactory and saved in the Results folder, close 

the Composer window. Open the Properties window of the layer and go to the Style tab 

once more. On the top, change from Categorized to Graduated. Now, choose the 

MinimumOverallLCOE2030 column on the top to display the LCOE achieved in each cell. 

Press Classify, Apply and OK to draw the LCOE map.   

Open the Composer window and insert a Title, Legend and Scale bar and save the new 

map once satisfied with the layout. 
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Congratulations for completing the hands-on exercises! If 

you have questions or want to contribute to the OnSSET 

community please go to onsset.org to find out more! 


